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Automatic Demo Examples

There are several examples with actual data installed with GRIDSTAT. The steps of the examples are recorded in
the *.REC files. To run the examples as automatic demo runs, go to the Tools pull down menu Play Demo, and
select one of the files.

To speed up a demo run, press Enter. To stop a demo run, press the ESC key. To change the delay time, go to Tools
pull down menu Preference. 0 is fastest.

Each demo example is outlined below. Some of the examples are detailed in the tutorials.

3DFAULT

Objective

This example is to generate a 3D model of vshale (lithology) with given markers. A sloping fault is added as marker
points. Well 63 is shifted to illustrate curve editing.

Input:

1. Horizon Markers in a text file.

2. VShale logs in a text file with keywords for well, x, y, and kb.

Process and Output:

1. Import markerheader file and then LOG file.

2. Graphically edit a well to depth shift it.

3. Add fault as new marker and graphically edit on cross section.

4. Map fault surface as a horizon surface

5. Map horizon surfaces with fault surface constraint.

6. Build 3D vsh model by Kriging.

7. Calculate net thickness map to show thickness reduction in the normal fault area.

8. Graph faulted grid with fault grid option on.

Run time: about 5 to 10 minutes.

3DMODEL

Objective

This example is to generate a 3D model of vshale (lithology) with given markers. Conditional simulation is used to
study uncertainty. Geobodies are generated.

Input:

1. Horizon Markers in a text file.

2. VShale logs in a text file with keywords for well, x, y, and kb.
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Process and Output:

1. Import markerheader file and then Log file

2. Variogram and model fit.

3. 3D model of VShale by Kriging.

4. Predict VShale log at new well location.

5. 3D models of VShale by Conditional Simulation.

6. Volumetrics calculation with the models.

7. Geobody with one realization of the models.

8. 3D model of VShale by Kriging with fault.

9. Various graphic views of the results.

10. Add a deviated new well and predict the log.

Run time: about 20 to 40 minutes.

EROSION

Objective

This example is to generate a 3D model of apparent porosity with given marker. The base marker is used for
porosity gridding. Top marker is erosional and mapped later. The grid is eroded with the surface.

Input:

1. Horizon Markers in a text file. Top horizon erosional. Base conformal.

2. Porosity logs in a text file with keywords for well, x, y, and kb.

Process and Output:

1. Import markerheader file and then Log file

2. Identify and remove wrong data: porosity <-100 or > 100.

3. Identify and correct KB error for one well.

4. Convert porosity from percentage to decimal unit.

5. Remove data above erosional top surface.

6. Variogram and model fit with base marker only.

7. Build 3D porosity model by Kriging with base marker only.

8. Turn off base marker and turn on top marker, build top surface.

9. Graph surfaces.

10. Remove portion of the porosity grid above top erosional surface.

Run time: about 7 to 15 minutes.

HMARKER

Objective

This example is to generate a 3D model of resistivity to define lithology. Bad data removal and normalization are
necessary for this dataset. A horizon marker is generated by correlation. Lithology grid is kriged with this horizon.
More markers are added and interactively edited. A horizon grid is generated based on all results.
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Input:

Resistivity logs in a text file with keywords for well, x, y, and kb.

Process and Output:

1. Import log data and data quality control.

2. Generate automatic horizon based on correlation among resistivity logs.

3. Variogram and model fit.

4. Normalize resistivity logs to compensate for temperature variations etc.

5. Build 3D lithology model by Kriging. High resistivity indicates sand.

6. Add new horizon markers, initially parallel to the auto-horizon.

7. Interactively modify the markers on cross sectional graph to top of sand.

8. Use autopick function to adjust the markers.

9. Autopick complete sand top surfaces based on 3D grid and well picks.

Run time: about 10 to 20 minutes.

LASNPOR

Objective

This example is to generate a 3D model of porosity with normalization from GR to VSH and NEUT to POR.
Cokriging is used to build the porosity grid. Colocated cosimulation is used for permeability grid.

Input:

1. Horizon Markers in a text file with X, Y, and KB.

2. GR logs, porosity logs, and core data in LAS files.

Process and Output:

1. Import markerheader file and then LAS files.

2. Data quality control.

3. Normalize GR logs to become VSH.

4. Normalize NEUT logs to porosity (one of many methods).

5. Variogram and model fit.

6. Build 3D porosity model by Kriging.

7. Correlate porosity to core permeability. Transform porosity grid to soft data.

8. Build 3D permeability model by colocated cosimulation.

9. Map k*H and make graphs.

Run time: about 15 to 30 minutes.

LITHOLOGY

Objective

This example is for modeling lithology or fluid indicator with interpreted indicators and markers. XYKB is in a
separate file imported Renew Header. Markers are in row based format with Topname column. The indicators here
are oil, gas, and water in sand.
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Input:

1. Indicator log text file.

2. Well x, y, and kb text file.

3. Horizon markers in a text file.

Process and Output:

1. Import indicator log as lithology data.

2. Import XYKB as renew header.

3. Import markers as row based format.

4. Data quality control and remove indicator values > 3 to concentrate on oil, water, and gas.

5. Variogram and model fit.

6. Build 3D indicator model by Kriging.

7. Build 2 conditional simulation realizations for comparison.

8. Graph results.

Run time: about 15 to 25 minutes.

MAKEMAP1

Objective

This example is to generate a map of formation top. A finer grid is then used to locate a possible fault. Gridding is
repeated with added fault

Input:

A text file of top of structure at wells with XY coordinates.

Process and Output:

1. Import layer data and data quality control.

2. Variogram and model fit.

3. Build 2D structure model by Kriging.

4. Calculate discontinuity of structure map to locate fault.

5. Determine fault location with multiple graphs.

6. Add fault on basemap.

7. Build 2D structure model by Kriging with fault.

Run time: about 5 to 10 minutes.

MAKEMAP2

Objective

This example is to generate a map of formation thickness. The zero thickness region is honored by matching data
distribution.

Input:

A text file of thickness with XY coordinates.
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Process and Output:

1. Import layer data and data quality control.

2. Variogram and model fit.

3. Build 2D model by Kriging.

Run time: about 1 to 3 minutes.

MAKEMAP3

Objective

This example is to generate a map of formation thickness. The zero thickness region is honored by matching data
distribution

Input:

A text file of thickness with XY coordinates.

Process and Output:

1. Import layer data and data quality control.

2. Variogram and model fit.

3. Build 2D model by Kriging.

Run time: about 1 to 3 minutes.

POR3WEL

Objective

This example is to generate a 3D model of porosity with given markers. A cross section is drawn through the three
wells. Two wells are deviated.

Input:

1. Horizon Markers in a text file.

2. Porosity logs in a text file with keywords for well, x, y, and kb.

Process and Output:

1. Import data and data quality control.

2. Variogram and model fit.

3. Build 3D porosity model by Kriging.

Run time: about 4 to 7 minutes.

PRODOIL

Objective

This example starts with production history. Build time animation of oil rate, gas oil ratio, and water cut map. Other
graphs are also available. The oil rate map may be compared with K*H map.

Input:

1. Monthly production rate of oil, gas, and water.
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Process and Output:

1. Import time based production history.

2. Remove shut-in data.

3. Calculate gas-oil-ratio and water-cut.

4. Variogram and model fit.

5. Build 3D grid with time as Z axis.

6. Graph time animation of oil rate, gas-oil-ratio, and water-cut.

Run time: about 5 to 10 minutes.

SEISMIC

Objective

This example is for simulating a 3D earth model, make synthetic seismic volume, and then invert seismic amplitude
to impedance. An alternative approach of model based inversion is tried later with log based initial model.

Input:

None

Process and Output:

1. Simulate an earth model with deposition simulation option.

2. Use Ricker wavelet and linear time to depth function to generate synthetic seismic data volume from the earth
model.

3. Invert seismic to impedance with same Ricker wavelet and time to depth function, without constraint or reference
grid.

4. Graph results and compare with earth model.

5. Sample the 4 corners of the earth model to make wells with VSH logs.

6. Remove inversion grid to start over.

7. Sample the seismic grid for the 4 wells.

8. Graph time to depth correlation search.

9. Search wavelet.

10. Add marker for building a well log based model.

11. Calculate variogram.

12. Build pseudo impedance grid with VSH logs.

13. Invert seismic with well log based impedance grid as reference.

14. Graph results.

Run time: about 30 to 50 minutes.

SIMULATION

Objective

This example is to generate a 3D model of porosity with given markers. A cross section is drawn through the three
wells. Two wells are deviated
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Input:

None

Process and Output:

1. Generate 3D porosity model by simulation.

2. Change variogram correlation ratio and generate model again.

3. Specify variogram, mean, and standard deviation for permeability model, log-normal.

4. Generate 3D permeability model by simulation.

5. Sample the permeability grid to become data traces.

Run time: about 5 to 10 minutes.

SOFTGRID

Objective

This example is to generate a depth map of formation top with seismic time pick as soft data grid. Cross plot is used
to define average velocity for time depth conversion because no other velocity is available.

Input:

1. Horizon picks from seismic time data in a text file.

2. Well markers in depth in a text file.

Process and Output:

1. Import time pick data and save as grid.

2. Import well marker data.

3. Sample time pick grid at well locations.

4. Correlate time pick data with well marker data.

5. Convert time pick grid to soft data grid.

6. Variogram and model fit.

7. Build 2D structure grid with colocated cokriging.

Run time: about 6 to 12 minutes.
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Basic Steps

Project Panel:
Project panel provides an overview of the current project.

Minimum step in this panel

1. Click the Next button on the lower left.

Points to check in this panel

1. At the first field on the left of bottom line, check if you are in the correct project.  If the bottom line is outside
the viewing area, move it to the viewing area.  To start a new project with new data, go to the File pulldown
menu and click New.  The new project will be named UNTITLED. To save the results for later use, use Save
As from the File pulldown menu and give a project/file name.  If you only want to save the data, not the grid,
check Save Data Only on the Save As panel.

2. At the bottom line, check if you are in the correct working directory.  You may create a separate working
directory for different field or different user, then point the icon/shortcut to that working directory.  Once you
are in GRIDSTAT, all data and output will be in that working directory.  The only time you can read data from
other directories is in the Import panel.

3. If you expect to have data file available, there should be a check mark in the box to the right of Data File.

4. If you expect to have marker file available, there should be a check mark in the box to the right of Marker File.

5. If you expect to have calculated variograms, there should be a check mark in the box to the right of
Variogram.
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6. If you expect to have generated a grid, there should be a check mark in the box to the right of 3D Grid.

7. Different versions of GRIDSTAT have different data loading limits.  A small version takes up less memory by
skipping large datasets.  Go to the Help pulldown menu and select About to see the current limit.

Import Panel:
Import panel reads outside data files into GRIDSTAT database.

Minimum steps in this panel

1. Click the Data Import pulldown list at the top, then select the import type, e.g. From Layer Data

2. For Log Data import, select the correct File Type on the upper right of the panel to Match Keyword or use
Las/Match Filename etc.

3. Check the box in front of the desired file in the file list, e.g. TESTMRK.DAT

4. Click the Preview button, then select As Text or As Data

5. Click the Convert button

If the target data files are already in GRIDSTAT format and in the correct directory and of correct file name, either
because you have imported them before or copied from somewhere, you do not need to import data now.  In that
case you may skip the Import Panel.

If you need to check or change import parameters, pull down the Options menu and select ImportPar…. Some
important parameters to consider: DZ Minimum and Maximum for selecting sampling vertical spacing during
import. Import Markerfile Null Value for the null value used in the file to be imported (default -999.25, which
during import of markerfile will be replaced by the GRIDSTAT null of -99999).

Points to check in this panel
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1. At the bottom line, check if you already have data in this project.

2. At the bottom line, check if you have enough disk space free for saving data.

3. Select the correct type of import at the top of the panel.  Select correct file type for log data import at the top
right of the panel.  For time data, use log data format.

4. Select the correct file to import.  You may select multiple files for log data import.

5. Check or select the correct label for the data columns after Preview.  All horizon markers are called “top”
here. The last “top” will be used as the bottom.  The marker depths should be in subsea (negative below sea
level).  Deeper markers should be to the right of shallower markers.

6. Make sure that the marker file (or header file with XYKB) has the same well names as the well log data file.

7. If file name match is selected (without keyword to match XYKB), make sure that the marker file (import type
Markerheader) is imported before the well log data files and the XY locations are imported in the marker file.
The well names imported in the marker file should be the same as the log data file names, and KB is imported
from marker file if the log data is in measured depth. If no marker is available, XYKB can still be imported as
markerheader file. Alternatively use Renew Header to read in the XYKB.

DataQC Panel:

DataQC panel provides a graphical environment for data quality control.

Minimum step in this panel

1. Click the Next button on the lower left.

This panel is used to quality control (QC) the data before further analysis and gridding.
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Points to check in this panel

1. Use the Table and Graph pulldown menus to open more tables or graphs.  Click at one of the four picture areas
to make it active.  Double click it to toggle between 1 Graph view and 4 Graph view or use View pulldown
menu to arrange graph views.  When you open a graph, it will be placed in the active area.

2. Examine the Data View and Data Quality tables to identify potential data problems.

3. To check trace by trace statistics details, open Statistics from the Table pulldown menu, and modify the table
from the Table pulldown menu Table Design.

4. Check if the well locations are correct in the basemap.

5. The first two groups in the Graph pulldown menu allow well/trace selection.  Click the Select button on the
left of the panel and turn Pick Well on to pick the wells you want to graph, or use Pick Box to select wells
within a box.  Data trace, cross plot, cross section, etc. will follow the selected well sequence.  You may select
or deselect a well in any one of those graphs and the selection will show up in other graphs of those two
groups.  You may need to use Redraw or Reset from the View pulldown menu to refresh the graphs.

6. If the project contains more than one type of data, select the desired primary data by going to Options
pulldown menu Data&Units panel.

7. For markers, make sure that all wells have corresponding markers (ideally there should be 100% match
between wells and markers), that there is data in the corresponding zones (compare Depth Range and
Markers graphs), and that the zone thickness is positive.

8. Data modifications performed with the Remove and Change buttons on the left of the panel are not saved to
the file until you do so by Save As.  To view the unsaved changes, use Tools pulldown menu and select View
Data Change.

9. To add data to the current data, go to File pulldown menu FindFile panel, select the desired data file, then
Add to the current data.  To add traces close to current wells or fansection, give a side distance from the
Options pulldown menu Fansection panel.

10. If you don’t have time to correct the data problems, it is better to remove the problem data.

Variogram Panel:

Variogram panel handles variogram calculation, modeling, and graphs.

Minimum steps in this panel

1. Click the Points button on the left of the panel

2. Click the Curve button, then select Spherical

3. Click the Next button on the lower left.
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Points to check in this panel

1. Make sure you have multiple wells if you want to calculate areal variogram.

2. You need multiple data points in each trace to calculate vertical variogram.

3. You can turn off markers from the Options pulldown menu Markers panel.

4. Make sure there are correct markers (check in DataQC panel) if you want to honor the horizons.  Data
between the top marker and the last marker will be used.

5. If you don’t have markers, areal variograms will be calculated in the horizontal direction.

6. If the project contains more than one type of data, select the desired primary data for variogram calculation by
going to Options pulldown menu Data&Units panel.

7. Calculate the variogram points first.

8. Curve fit the variogram points.  The fit is automatic as soon as you choose a model.  Use spherical model for
stable fit.  Use log-log scale graph and different fractal power to fine tune.

9. Variograms usually increases with distance.

10. Well Pair Variance graph is a good indicator of data quality.  For those well pairs that are in short distance but
showing relatively large variance, there is usually problem in the data, well location (including adjustment for
deviated wells), or marker depth.

11. Correlation Ratio to Vertical (CR_v) is usually larger than 10 (50, 100, 1000 depending on the data) if the
vertical scale is depth.  From the Model button on the left you can select default values of CR_v for various
geological environments.  If vertical scale is layer index (when imported as layer data), it depends on the layer
thickness and whether the data in different layers are correlated.
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GridOption Panel:

GridOption panel provides variogram model input for gridding.

Minimum step in this panel

1. Click the Next button on the lower left.

This panel shows the actual variogram parameters for gridding as well as control point search parameters.

Points to check in this panel

1. The parameters from variogram modeling are automatically copied to this panel. Click the Model button on
the left and select From Variogram to copy those parameters again.

2. Make sure the major correlation length, which is the longest correlation length of the correlation ellipsoid and
the distance limit of data search, is reasonable.  You may need to increase it to cover areas far from control
data, or reduce it to avoid extrapolating too far from control data.  Large search radius may result in longer
gridding time if the number of control data is large.

3. Make sure Correlation Ratio to Vertical (CR_v) is reasonable.  Too small a CR_v will disrupt the layer-like
character while too large a CR_v will make the layering too continuous.  Get more information about the local
geology and try different ratios to compare the results.

4. If you only want to see the results within zone boundaries, such as for flow simulation, and you have markers
included, select Grid Along Marker.

5. Minimum number of control points per node is required for a grid cell to have valid value.

6. Maximum number of control points per node is chosen as a compromise between accuracy and speed.
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7. Initial search radius is the starting search radius for automatic adjustment between the minimum and the
maximum.

GridSize Panel:

GridSize panel defines the dimension of the grid to be generated and starts gridding.

Minimum steps in this panel

1. Click the Start button on the upper right

2. Click the Next button on the lower left

Points to check in this panel

1. The initial grid dimension is designed to cover all the data and have 10 cells in each horizon direction.  Make a
coarse grid first.  You can redefine the cell sizes to make a finer grid or covering more area later.

2. Make sure the grid definition is consistent with the data coverage.

3. Make sure Log-Normal Data option is on if the data is resistivity or permeability.

4. Do Kriging first even when your final goal is conditional simulation.  This will give you a base case.

5. If you don’t have any data, conditional simulation is unconditional simulation and a grid can be generated
(simulated heterogeneity).

6. If you have changed some parameters and want to reset, use File pulldown menu Reset then Gridding Input,
and you may use the saved parameters file or use defaults calculated from the data by skipping the parameter
file.  Note that this reset also resets the GridOption panel parameters.
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7. If you want to use the same input parameters as in another project, go to File pulldown menu FindFile panel,
select GriddingPar files to list, select the desired file, then click the Read button on the right. Note that this
also reads the GridOption panel parameters.

8. To use an existing horizon grid which is consistent with the current markers, go to Options pulldown menu
GriddingData panel, select DepthGrid files to list, select the desired file, then click the As Horizon button
and select Yes.

9. To include soft data which has been calibrated to the current data, go to Options pulldown menu
GriddingData panel, select the desired data file, then click the Softdata button and select Yes.  The soft data
search radius should be modified to reflect the spatial distribution of the soft data.

10. To make the grid to be saved as a specific type instead of generic attribute grid, go to Options pulldown menu
Data&Units panel and select the desired Primary data Type.

GridOutput Panel:

GridOutput panel provides visualization, calculation, and export of grids.

Minimum step in this panel

1. Click GGraph button on the upper left of the panel, then select 3D View.

Points to check in this panel

1. Use the GGraph button on the left of the panel to graph the active grid, which is selected on the lower right if
there are multiple grids.

2. Use the Range button on the left of the panel to slice the 3D grid.
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3. Modify the pictures from Option button on the left or from the Options pulldown menu Graphpar or
GridGraph panel.

4. Use the Export button on the left of the panel to export the grid for other software.

5. For most data, the graphed grid should show lateral continuity but not complete continuity.

6. Be aware of the aspect ratio.  Typically the vertical scale is exaggerated for better viewing, this may cause the
result to appear less continuous in the horizontal direction.

7. If the grid has been made to follow markers, you should be able to show the result in Structure.

8. For depth grid or single layer grid or if the Data Type is Depth (select from Options pulldown menu
Data&Units panel), you should be able to show the result in Structure.

9. If grid does not show the layering as you expected, check whether the markers are correct and the variogram is
showing correct lateral continuity (40<CR_v <2000).

10. If you don’t see the whole grid in display, check if grid dimension is consistent with data coverage and the
search radius is large enough. If markers are used, from DataQC panel and GridSize panel check if there is
data within the zones. Grid cells too far from control data may contain null value.

11. If there seems to be artifacts in the grid, check if the markers are correct, the data is consistent among different
wells, the search radius and points per node are large enough, and the variogram model is suitable.




